Конспектирую то, с чем сам возился трое суток.
Задача: есть готовое решение с готовыми web-сервисами. Необходимо поднять и настроить на локальном компьютере для модификации или разработки ASP.NET приложения или любого другого приложения C#, использующего эти веб-сервисы.

Прежде всего — очень полезная статья на эту тему. В конечном итоге она и помогла.
И вот тут еще одна — есть некоторые частности по настройке безопасности.
На предмет взаимодействия ASP.NET-сайта с такими сервисами — есть неплохой материал на Хабре: Обмен 1С c клиентом на C# используя веб-сервисы 1С
ЗДЕСЬ — бэкап этой статьи на моем readability

На всякий случай, если публикации пропадут из Инета — прикладываю PDF-версию из первой ссылки.
2012_Tavalik.pdf

 

Особенности, с которыми столкнулся:
В моем случае база и веб-сервисы были опубликованы с указанием наименования виртуальной директории 1c-cargo
следует помнить, что при этом wsdl-описание в таком случае доступно по следующему адресу:
http://localhost/1c-cargo/ws/<файл-алиас сервиса>?wsdl
НЕ ЗАБЫВАТЬ «ws»!

  1. Создаем раздел с именем «{84A3E023-8F84-4a8a-8CD9-22425B5DA137}» в ветке HKEY_CLASSES_ROOT\wow6432node\appid
  2. Для этого раздела создаем строковое свойство «DllSurrogate» с пустым значением.
  3. Находим HKEY_CLASSES_ROOT\wow6432node\CLSID\{84A3E023-8F84-4a8a-8CD9-22425B5DA137} и добавляем строковое свойство «AppID» со значением «{84A3E023-8F84-4a8a-8CD9-22425B5DA137}».

Задача: файл, находящийся на клиенте, передать на сторону сервера и обработать.
Хитрость в том, что пользователь в клиентском интерфейсе 1С выбирает файл в своей локальной ФС, а обрабатываться он должен на стороне сервера.
Простейший вариант работы — передавать через специально реализованное для этого хранилище значений в сервере 1С.
Сначала конечно надо узнать, откуда брать файл. Поэтому в форму встраиваем строковый реквизит с соответствующими элементами управления.
По действию выбора значения запускаем вот такую процедуру:


Процедура рфПутьКнигиЭксельНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);

ТкстФильтра = "ru = ""файлы Excel""; en = ""Excel files""";

Фильтр = НСтр(ТкстФильтра)+"(*.xls)|*.xls";

Диалог.Фильтр = Фильтр;

Диалог.МножественныйВыбор = Ложь;

Диалог.Заголовок = "Выберите файл для загрузки";

Если Диалог.Выбрать() Тогда

МассивФайлов = Диалог.ВыбранныеФайлы;

Для Каждого ИмяФайла Из МассивФайлов Цикл

рфПутьКнигиЭксель = ИмяФайла;

КонецЦикла;

Иначе

Текст = "ru = ""Файл не выбран""; en = ""File not selected""";

Сообщить(НСтр(Текст));

КонецЕсли;

КонецПроцедуры

Дальше уже надо работать собственно с файлом.
Для этого


&НаКлиенте

Процедура СчитатьКнигу(Команда)

ФайлКниги = Новый Файл(рфПутьКнигиЭксель);

Если (НЕ ФайлКниги.Существует()) Тогда

Сообщить("Не могу найти указанный файл: " + ФайлКниги.ПолноеИмя);

Возврат;

КонецЕсли;

ПомещаемыеФайлы = Новый Массив;

АдресФайлаВоВременномХранилище = "";

ПоместитьФайл(АдресФайлаВоВременномХранилище, ФайлКниги.ПолноеИмя, , Ложь, ЭтаФорма.УникальныйИдентификатор);

СчитатьФайлТаблицы(АдресФайлаВоВременномХранилище);

КонецПроцедуры

 

И управление передается в серверную процедуру СчитатьФайлТаблицы():


 

Процедура СчитатьФайлТаблицы(Знач АдресФайлаВоВременномХранилище)

ИмяВремФайла = ПолучитьИмяВременногоФайла(".xls");

ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресФайлаВоВременномХранилище);

ДвоичныеДанные.Записать(ИмяВремФайла);

ПолученныйФайл = Новый Файл(ИмяВремФайла);

Если (НЕ ПолученныйФайл.Существует()) Тогда

Сообщить("Не получилось передать файл на сервер :(");

Иначе

Сообщить("Файл успешно передан на сервер и лежит вот тут:

|" + ПолученныйФайл.ПолноеИмя);

КонецЕсли;

КонецПроцедуры

 

1.Настроить System DSN на той машине, с которой будет осуществляться доступ

2. Не забыть, что если система 64-битная, — то DSN надо настраивать из 32-битной c:\windows\sysWOW64\odbcad32.exe и при этом должен стоять 32-битный коннектор MySQL (отсюда: http://dev.mysql.com/downloads/connector/odbc/ ) ибо клиентская часть у 1С — 32-битная, и при несовпадении Винды ничего не найдут и будут ругаться.

3. Строка соединения должна быть такая: «DSN=dsnname» и все

4. Дальше пишем:

СтрПодключения = "DSN=dsnname";

Попытка

Соединение = Новый COMОбъект("ADODB.Connection");

Исключение

Сообщить("Не удалось подключиться к базе данных.");

Сообщить(ОписаниеОшибки());

Возврат Ложь;

КонецПопытки;

Соединение.ConnectionString = СтрПодключения;

Попытка

Соединение.Open();

Исключение

Сообщить("Не удалось подключиться к базе данных.");

Сообщить(ОписаниеОшибки());

Возврат Ложь;

КонецПопытки;

Попытка

КЫ = Новый COMОбъект("ADODB.Recordset");

Исключение

Сообщить("Не удалось подключиться к базе данных.");

Сообщить(ОписаниеОшибки());

Возврат Ложь;

КонецПопытки;

КЫ.ActiveConnection = Соединение;

Ткст = "select * from sql_dbname.products LIMIT 5;";

КЫ.Open(Ткст);

Получить оттуда данные — отдельная тема.

Платформа 1С 8.2

симптомы: процесс rphost.exe кушает очень много памяти, не освобождая ее.

попытка решения:

1. Увеличить количество рабочих процессов сервера

2. настроить перезапуск сервера в свойствах кластера серверов

3. настроить допустимый объем памяти в свойствах кластера серверов

 

Предыстория: сразу после установки платформы 1C 8.2.16.352 при запуске баз в режиме исполнения стала появляться вот такая ошибка:

«Точка входа в процедуру ?fill_excepinfo@core@@YAXAAVException@1@PAUtagEXCEPINFO@@@Z» не найдена в библиотеке DLL core82.dll»

Как оказалось, это ошибка неверной установки платформы. До конца не выяснил, речь об установке клиентской части или серверной. Переустановил обе — сработало.

Осталась ошибка, выдаваемая сразу после этого в панель сообщений:

Класс не зарегистрирован

Эта ошибка оказалась следствием первой, хотя и не взаимооднозначным.

Решается регистрацией dll-компоненты comcntr.dll следующим образом:

regsvr32 comcntr.dll

(делать в директории, в которой находится компонента, желательно текущей редакции платформы. Или же указывать полный путь к dll-файлу).

Версия 2.0.32

Новое в версии 2.0.32.6

  • Подготовка данных персонифицированного учета ПФР
  • Регламентированная отчетность
    • В состав форм регламентированной отчетности добавлены:
      • Расчет по авансовому платежу по налогу на имущество организаций, утвержденный приказом ФНС России от 24.11.2011 № ММВ-7-11/895;
      • Декларация по налогу на добычу полезных ископаемых, утвержденная приказом ФНС России от 16.12.2011 № ММВ-7-3/928@;
    • Выгрузка в электронном виде формы РВ-3 ПФР в редакции приказа Минздравсоцразвития России от 03.11.2011 № 1322н реализована в формате, утвержденном распоряжением Правления ПФР от 28.12.2011 № 505р;
    • В порядок заполнения Расчета по начисленным и уплаченным страховым взносам на обязательное социальное страхование на случай временной нетрудоспособности и в связи с материнством и по обязательному социальному страхованию от несчастных случаев на производстве и профессиональных заболеваний, а также по расходам на выплату страхового обеспечения (Форма-4 ФСС РФ) внесены изменения в соответствии с письмом ФСС РФ от 28.12.2011 № 14-03-18/04-16256 и приказом Минздравсоцразвития России от 22.11.2011 № 1385н;
    • Реализована возможность отправки в ФНС по телекоммуникационным каналам связи бухгалтерской отчетности с приложениями, в соответствии с приказом ФНС РФ от 28.12.2011 № ММВ-7-6/986@ «О внесении изменений в Приказ ФНС России от 09.11.2010 № ММВ-7-6/535@»;
    • В конфигурации обновлены шаблоны машиночитаемых бланков.

Новое в версии 2.0.32.4

  • Добавлен сервис интернет-поддержки
    • Информацию по сопровождению конфигурации можно получить, не выходя из программы: сроки окончания договора 1С:ИТС, мониторинг новых версий программы, форм регламентированной отчетности, последние новости по сопровождению конфигурации и т.д.
  • Реализованы новые формы счета-фактуры, корректировочного счета-фактуры, журнала полученных и выставленных счетов-фактур, книги покупок и книги продаж в соответствии с Постановлением Правительства РФ от 26.12.2011 г. № 1137 «О формах и правилах заполнения (ведения) документов, применяемых при расчетах по налогу на добавленную стоимость»;
  • Налог на прибыль
    • Добавлен новый вид прочих доходов с видом «Корректировка прибыли до рыночных цен» для учета доходов от корректировки прибыли вследствие применения методов соответствия рыночных цен и цен реализации (ст. 105.12, 105.13 НК РФ);
    • Добавлен новый вид прочих расходов с видом «Прочие убытки, приравненные к внереализационным расходам» для учета убытков, учитываемых в составе внереализационных расходов (п.2 ст. 265 НК РФ), связанных со следующими причинами:
      • Потери от простоев по внутрипроизводственным причинам не компенсируемые виновниками потери,
      • Потери от простоев по внешним причинам,
      • Расходы в виде недостачи материальных ценностей в производстве и на складах, на предприятиях торговли в случае отсутствия виновных лиц, а также убытки от хищений, виновники которых не установлены,
      • Потери от стихийных бедствий, пожаров, аварий и других чрезвычайных ситуаций, включая затраты, связанные с предотвращением или ликвидацией последствий стихийных бедствий или чрезвычайных ситуаций,
      • Убытки по сделке уступки права требования;
  • Отчетность по НДФЛ за 2011 год
    • Перечень доходов и вычетов по НДФЛ, а также порядок формирования справок о доходах 2-НДФЛ соответствуют приказу ФНС РФ от 06.12.2011 г. № ММВ-7-3/909@ «О внесении изменений в приложения к приказу Федеральной налоговой службы от 17.11.2010 г. № ММВ-7-3/611@»;
  • Регламентированная отчетность
    • Для формы регламентированной отчетности «Сведений о доле доходов организации от осуществления образовательной и (или) медицинской деятельности в общей сумме доходов, о численности работников в штате организации и о численности медицинского персонала, имеющего сертификат специалиста, в штате организации» (утверждены приказом ФНС России от 21.11.2011 № ММВ-7-3/892@) включена возможность печати машиночитаемого бланка с двухмерным штрихкодом PDF417 в связи с публикацией ФНС России шаблона машиночитаемой формы;
    • В конфигурации обновлены шаблоны машиночитаемых бланков;
  • Исправлены выявленные ошибки.

Смотрите также

  1. Релиз предназначен для обновления с конфигурации версии 2.0.32.4. Порядок обновления и дополнительная информация приведена в файле 1cv8upd.htm;
  2. Порядок обновления релиза и дополнительная информация приведена в файле ReadMe.txt;
  3. Перечень изменений в релизе и исправленные ошибки приведен в файле Бухгалтерия предприятия. Версия 2.0.32. Изменения в версии.mxl;
  4. Конфигурация адаптирована для использования с платформой «1С:Предприятие 8.2» Инструкция по переходу содержится в файле 1cv8upd.htm.

Все, что может быть интересного на этот счет, мы публикуем на отдельном ресурсе.

Добро пожаловать: http://1137.ru/

Потрясающе!
Конфигурация решения, которое я решил поднять снова в разработку, было основано на конфигурации Библиотека Стандартных Подсистем.
Но вот только, как выясняется, оно было основано на версии, которую я неизвестно как и неизвестно где достал. По всем признакам это официальная версия — с официальным комплектом поставки и проч. Только ее сейчас нигде нет! Ни на сайте 1С, ни на дисках ИТС, ни на одном известном мне пиратском сборище!
ГДЕ я умудрился ее достать?!

УРА! Сертификат мой!
1С:Профессионал по платформе 8.2